Seite 5 von 6 ErsteErste 123456 LetzteLetzte
Ergebnis 61 bis 75 von 79

Thema: Boswatch Raspberry-Image; POCSAG decodierung

  1. #61
    Registriert seit
    17.12.2016
    Beiträge
    10
    Zitat Zitat von thilo Beitrag anzeigen
    Kommen denn halbwegs vernünftige Signale rein, sprich ist eine RIC erkennbar samt Text?

    Gesendet von meinem D5803 mit Tapatalk
    Nee, im Multimon kommt gar nichts an

  2. #62
    Registriert seit
    17.12.2016
    Beiträge
    10
    Zitat Zitat von etueu35u35 Beitrag anzeigen
    Bei SDR# musst du nur bei den Zahnrad die Freq korrektur einstellen sonst nix machen.
    Die Frequenzkorrektur versuche ich ja eben dementsprechend einzustellen. Aber mit der Standard-Samplerate von 2048 höre ich beispielsweise außer weißem Rauschen gar nichts und es schlägt auch neben der "Zielfrequenz" im Spektogramm nichts aus.

  3. #63
    Registriert seit
    08.07.2014
    Beiträge
    303
    In SDR# siehst du alles?

  4. #64
    Registriert seit
    17.12.2016
    Beiträge
    10
    Zitat Zitat von etueu35u35 Beitrag anzeigen
    In SDR# siehst du alles?
    Das ist ja das Kuriose:

    Ich hatte irgendwie eine Einstellung (Mischung aus anderer Sample-Rate und Bandbreite usw ) gefunden, mit der ich im SDR# die Pocsag-Signale gesehen und auch gehört hatte. Das Komische war aber, dass das Signal immer links und rechts der "Zielfrequenz" zu sehen war. Ca. 15kHz links und rechts.

  5. #65
    Registriert seit
    08.07.2014
    Beiträge
    303
    Mache mal ein Screenshot.

  6. #66
    Registriert seit
    17.12.2016
    Beiträge
    10
    Also das hier sind meine Einstellungen im SDR#: Bild 1

    Und das ist das, was angezeigt wird: Bild 2


    Er empfängt hin und wieder (sehr unregelmäßig) knapp neben der eingestellten Frequenz irgendwelche Pocsag-Signale, allerdings nicht die, die auf der Frequenz eigentlich kommen sollten (zum Vergleich steht nebenan ein Hardware-Empfangsgerät).

    Was mir noch auffällt ist, dass trotz geöffneter Rauschsperre das weiße Rauschen abgehackt ist.

    Zudem läuft im Terminal des Pi folgendes ab:

    ll+, now 1
    ll+, now 2
    ll+, now 3

    etc...

    ich weiß nicht, ob das normal ist, oder nicht. Den RTL_TCP-Dienst habe ich gestartet mit rtl_tcp -a 192.168.0.XXX (meine IP des Raspberry)
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	1.PNG 
Hits:	385 
Größe:	22,3 KB 
ID:	16915   Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	2.PNG 
Hits:	240 
Größe:	11,6 KB 
ID:	16916  

  7. #67
    Registriert seit
    08.07.2014
    Beiträge
    303
    Du hast bei der freq korrektion 0 drinnen stehen?!
    WTF WFM?!

    Stelle es auf NFM und 10.000khz

  8. #68
    Registriert seit
    10.12.2016
    Beiträge
    11
    Tipp: Greife mit SDRSharp per TCP/IP auf den SDR-Stick am Pi zu und stelle dabei als Frequenzkorrektur NULL ein. Dann wählst Du im Wasserfall das Pagersignal aus. Die Frequenz, die Du dann hast, gibst Du dann in das Kommando für den RTL-FM ein.
    Anleitung: http://thardes.de/raspberry-pi-als-sdr-server/
    Ach ja, noch was: Rauschsperre und Filter Audio ausmachen, dann gibt es auch gute Decodier-Ergebnisse.

  9. #69
    Registriert seit
    31.08.2016
    Beiträge
    23

    Es reißt nicht ab..

    Nachdem ich mir einen -augenscheinlich- sehr guten Stick von NooElec bestellt habe:

    https://www.amazon.de/NooElec-NESDR-...words=rtl2832u

    wollte ich den nächsten Test mit komplett neuer Konfiguration fahren.
    Die Blacklist habe ich mit RTL28xxx etc. versehen.

    Multimon NG ist installiert.
    Da es die neue Variante vom RTL2832u ist, bekomme ich bei "rtl_test" die Meldung:

    pi@raspberrypi:~ $ rtl_test
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    [R82XX] PLL not locked!
    Sampling at 2048000 S/s.

    Info: This tool will continuously read from the device, and report if
    samples get lost. If you observe no further output, everything is fine.

    Reading samples in async mode...
    lost at least 16 bytes




    Will ich aber BOSWatch ausführen, gibt es nur folgenden Fehler:

    pi@raspberrypi:~/BOSWatch $ sudo python boswatch.py -f 17x.xxxM -a POC1200
    usage: boswatch.py [-h] -f FREQ -d DEVICE [-e ERROR] -a
    {FMS,ZVEI,POC512,POC1200,POC2400}
    [{FMS,ZVEI,POC512,POC1200,POC2400} ...] [-s SQUELCH]
    [-g GAIN] [-u] [-v] [-q]
    boswatch.py: error: argument -d/--device is required

    Weiß jemand Rat?
    Vielen Dank schon mal :)

    Grüße
    Newman

  10. #70
    Registriert seit
    08.07.2014
    Beiträge
    303
    Scheinbar hast du keine Treiber drauf.

  11. #71
    Registriert seit
    08.12.2004
    Beiträge
    788
    Dir fehlt im Aufruf ein -d 0

    Gesendet von meinem D5803 mit Tapatalk
    No RICs, no fun.

  12. #72
    Registriert seit
    17.12.2016
    Beiträge
    10
    Zitat Zitat von Drehstrom Beitrag anzeigen
    Tipp: Greife mit SDRSharp per TCP/IP auf den SDR-Stick am Pi zu und stelle dabei als Frequenzkorrektur NULL ein. Dann wählst Du im Wasserfall das Pagersignal aus. Die Frequenz, die Du dann hast, gibst Du dann in das Kommando für den RTL-FM ein.
    Anleitung: http://thardes.de/raspberry-pi-als-sdr-server/
    Ach ja, noch was: Rauschsperre und Filter Audio ausmachen, dann gibt es auch gute Decodier-Ergebnisse.
    Hallo zusammen,

    ich habe es jetzt tatsächlich hinbekommen!

    Das Problem mit SDR# war, dass der Computer, auf dem SDR# lief, zu schwach auf der Brust war ;) Deshalb kam kein vernünftiges Audiosignal an :D

    Ich habe herausgefunden, dass die Frequenzkorrektur tatsächlich bei 60 ist, weshalb BOSWatch natürlich nichts dekodieren konnte. Jetzt funktioniert alles inkl. MYSQL - Plugin!

    Tolle Sache! Vielen Dank auch für eure Hilfe!

  13. #73
    Registriert seit
    31.08.2016
    Beiträge
    23
    Danke Thilo!
    So ein kleiner Parameter kann schon viel bewirken...

    Nun muss ich mal schauen, wie es mit kalibrierung etc. läuft - und wenn was vernünftiges bei rauskommt, stelle ich hier mal ein Image online.

    Nun muss es nur noch als Bosmon Eingabequelle taugen :).

  14. #74
    Registriert seit
    08.12.2004
    Beiträge
    788
    Zitat Zitat von Newman Beitrag anzeigen
    Danke Thilo!
    So ein kleiner Parameter kann schon viel bewirken...
    Ich sehe wir sollten den Parameter per default setzen - ich nehme das mal auf.

    Zur Kalibrierung scheint sich o.g. Hinweis mit SDR# als sehr wirkungsvoll zu erweisen. Wenn das gut klappt und ich meinen stummen Stick zum Rennen kriege packe ich die Anleitung in das Boswatch-Repo.

    Zu Bosmon kann ich leider null beitragen ;-)

    Gesendet von meinem D5803 mit Tapatalk
    No RICs, no fun.

  15. #75
    Registriert seit
    31.08.2016
    Beiträge
    23

    soweit sogut..

    Die Kalibrierung habe ich durchgeführt. Laut GSM-Referenz sind es gerade mal 0,005ppm Abweichung.
    Sieht also nach einem guten Stick aus (wobei halt das GSM-Band auch recht breitbandig ist).

    Auf jeden Fall habe ich nun eine saubere Auswertung.
    Bevor ich das Image online stelle, müsste ich noch irgendwie eine Bosmon-Übergabe zum Laufen kriegen.

    Ich habe in der config.ini bei Plugins bei Bosmon die "1" gesetzt.
    Als Channelname habe ich "poc" ausgewählt und den Port auf "80" gesetzt.

    In Bosmon selbst habe ich als Quelle "Bosmon Netzwerkkanal" gewählt und als Serveradresse meine IP des Raspi's eingegeben.
    Kanal natürlich auch wieder "poc" genannt, Port 80.

    Aber irgendwie baut Bosmon keine Verbindung auf?
    Weiß jemand rat?

    Grüße Newman.

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •