Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 20

Thema: Kalender Plugin funktioniert nur teilweise

  1. #1
    Registriert seit
    15.02.2011
    Beiträge
    359

    Kalender Plugin funktioniert nur teilweise

    Hallo Community,

    ich habe ein Problem mit dem Kalender Plugin.

    Ich löse damit jeden Freitag um 12 Uhr einen Probealarm aus.
    Im Google Kalender habe ich diesen Termin hinterlegt, dieser wiederholt sich jeden Freitag.
    Die erste Alarmierung funktioniert immer, jedoch die darauffolgende Woche nicht mehr.

    Ich habe auch beobachte, dass sich das Plugin ständig von selbst deaktiviert.

    Wenn dann Freitag nachts um 24.00 Uhr Das Plugin nach einem Event sucht meldet der Server, dass dieses Event in der Vergangenheit liegt.

    In FE ist vermutlich alles richtig eingepflegt, auch die Schritte zum einrichten des Kalender habe ich 1:1 befolgt.



    was mache ich falsch ?
    Geändert von speedy2lolo (06.02.2015 um 07:56 Uhr)

  2. #2
    feodor Gast
    Hi,

    was meinst du mit "deaktiviert sich" Gehen andere Termine auch nicht mehr?

    Da ja heute Freitag ist, kannst du bestimmt den Teil von heute 0:05 aus dem Log posten wo das Plugin nach Einträgen sucht.

    Haben andere auch Probleme?
    Im Beta Test ist nichts aufgefallen. Kommt mir vor wie ein Zeitzonen Problem.

    Gruß

  3. #3
    Registriert seit
    15.02.2011
    Beiträge
    359
    Ich aktiviere das Kalender Plugin am Donnerstag Abend z.b. Dann läuft der Probealarm problemlos, aber nur an diesen einem Event .

    Eine Woche später schaue ich am Freitag 24.00 Uhr in den log, und sehe, dass der Termin in der Vergangenheit ist, was aber nicht sein kann, da der Probealarm 1:1 jeden Freitag im Kalender steht.

    Dabei ist mir aufgefallen, dass das Plugin deaktiviert ist.

    Das ist mir schon öfters aufgefallen




    Gesendet von meinem iPhone mit Tapatalk

  4. #4
    feodor Gast
    Ohne Log kann ich nichts beurteilen...

  5. #5
    Registriert seit
    10.06.2007
    Beiträge
    567
    Bei mir taucht im Server immer das hier auf. Im Log steht aber nichts.
    Werde morgen sehen ob es Funktioniert. Bislang hat es immer Funktioniert.

    Hat die Warnung was zu sagen?


    Gruß
    Markus
    Miniaturansichten angehängter Grafiken Miniaturansichten angehängter Grafiken Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	Server.bmp 
Hits:	133 
Größe:	550,8 KB 
ID:	16300  

  6. #6
    Registriert seit
    15.02.2011
    Beiträge
    359
    Wenn ich zuhause bin, kann es Posten...


    Gesendet von meinem iPhone mit Tapatalk

  7. #7
    Registriert seit
    15.02.2011
    Beiträge
    359
    log, wo das Kalender plugin betreffen:

    06.02.2015 - 00:05:00.026 INFO CalendarInput - OAuth Credentials erfolgreich geladen
    06.02.2015 - 00:05:00.767 INFO CalendarInput - Verwende Kalender: GELÖSCHT
    06.02.2015 - 00:05:00.768 INFO CalendarInput - Suche von: Fri Feb 06 00:05:00 CET 2015
    06.02.2015 - 00:05:00.768 INFO CalendarInput - Suche bis: Fri Feb 06 23:59:59 CET 2015
    06.02.2015 - 00:05:01.140 INFO CalendarInput - Startpunkt des Events liegt in der Vergangenheit, überspringe...
    06.02.2015 - 00:09:35.920 INFO OutageController - Lebenszeichen geschickt


    es ist definitiv ein Termin im Kalender eingetragen und hat auch einmalig funktioniert.
    alle darauffolgenden Termine werden nicht mehr erkannt.

    Lösche ich diese Termine und trage einen neuen ein funktioniert es wieder nur einmal.


    @ feodor: Schreibe mich doch mal bitte an, damit ich dir den kompletten LOG schicken kann.

  8. #8
    Registriert seit
    15.02.2011
    Beiträge
    359
    Jemand ne Idee ?


    Gesendet von meinem iPhone mit Tapatalk

  9. #9
    Registriert seit
    10.06.2007
    Beiträge
    567
    Leider nicht so direkt. Bei mir Funktioniert alles.
    Schon mal die Zeitzone etc vom Rechner geprüft?
    Und die Zeitzone im Kalender geprüft?

    Das ist im Moment das einzige was mir einfällt.

    Gruß
    Markus

  10. #10
    Registriert seit
    09.01.2010
    Beiträge
    3.908
    Passiert das nur bei Terminen, die sich wiederholen?
    Das scheint ja vermutlich ein Problem zu sein.

    Wenn ihr den Termin Freitags "selbst" einträgt, funktioniert es?

    Ihr könnt übrigens auch mal auf DEBUG stellen, dann müsste man mehr über das Kalender-Event erfahren.

  11. #11
    Registriert seit
    15.02.2011
    Beiträge
    359

    Kalender Plugin funktioniert nur teilweise

    Ja das funktioniert bei einzelnen Terminen recht gut, alles was über einen Termin hinaus in den Kalender eingetragen wird funktioniert leider nicht. Der erste Termin der ,,Periode,, funktioniert allerdings.

    Debug Modus werde ich einschalten und zusätzlich mal täglich einen Probealarm nur für mich in den Kalender eintragen, dann wird man mehr erfahren können :).



    Gesendet von meinem iPhone mit Tapatalk

  12. #12
    feodor Gast
    Bitte mal wenn möglich einen sich täglich wiederholenden Eintrag machen und dann das debug log vom zweiten Tag Posten.
    Vielen Dank für die Unterstützung

    Gesendet von meinem Nexus 4 mit Tapatalk 2

  13. #13
    Registriert seit
    15.02.2011
    Beiträge
    359
    Hallo,

    ich habe das nun mal nachgestellt und ausprobiert
    Es wurde wieder kein Alarm ausgelößt.

    10.02.2015 - 00:05:00.583 INFO CalendarInput - Verwende Kalender:
    xxx@gmail.com
    10.02.2015 - 00:05:00.585 INFO CalendarInput - Suche von: Tue Feb 10 00:05:00 CET 2015
    10.02.2015 - 00:05:00.586 INFO CalendarInput - Suche bis: Tue Feb 10 23:59:59 CET 2015
    10.02.2015 - 00:05:00.701 DEBUG CalendarInput - Anzahl heutiger Events: 1
    10.02.2015 - 00:05:00.704 DEBUG CalendarInput - Verarbeite Event: {
    "created" : "2015-02-09T19:51:54.000Z",
    "creator" : {
    "displayName" : "Alarm Server",
    "email" : "xxx@gmail.com",
    "self" : true
    },
    "description" : "Probealarm test ",
    "end" : {
    "dateTime" : "2015-02-09T19:00:00.000+01:00",
    "timeZone" : "Europe/Berlin"
    },
    "etag" : "\"2847023028240000\"",
    "htmlLink" : "https://www.google.com/calendar/event?eid=N3FtZWlpYW5zdTh0NmVmajRlNGxsMmdhbHNfMjAx NTAyMDlUMTcwMDAwWiBhbGFybXNlcnZlcmtlbnppbmdlbkBt",
    "iCalUID" : "7qmeiiansu8t6efj4e4ll2gals@google.com",
    "id" : "7qmeiiansu8t6efj4e4ll2gals",
    "kind" : "calendar#event",
    "organizer" : {
    "displayName" : "Alarm Server",
    "email" : "xxx@gmail.com",
    "self" : true
    },
    "recurrence" : [ "RRULE:FREQ=WEEKLY;COUNT=5;BYDAY=MO,TU,WE,TH,F R" ],
    "reminders" : {
    "useDefault" : true
    },
    "sequence" : 0,
    "start" : {
    "dateTime" : "2015-02-09T18:00:00.000+01:00",
    "timeZone" : "Europe/Berlin"
    },
    "status" : "confirmed",
    "summary" : "Probealarm test ",
    "updated" : "2015-02-09T19:51:54.120Z"
    }
    10.02.2015 - 00:05:00.705 INFO CalendarInput - Startpunkt des Events liegt in der Vergangenheit, überspringe...


    Um 18.00 Uhr steht nichts bezüglich Kalender drin.

  14. #14
    Registriert seit
    09.01.2010
    Beiträge
    3.908
    Ja, das ist ein Fehler.
    Das Kalender-Input-Plugin prüft den "Start"-Wert, was in diesem Fall "2015-02-09T18:00:00.000+01:00"

    Zu dem Überprüfungs-Zeitpunkt (10.02.15), liegt der Termin tatsächlich in der Vergangenheit.

    Hier müssen wir das Plugin anpassen. Das kommt mit Wiederholungen noch nicht klar.

  15. #15
    Registriert seit
    15.02.2011
    Beiträge
    359
    Okay, super dann weis man ja jetzt den Fehler :).

    Ist das schnell behoben ?


    Gesendet von meinem iPhone mit Tapatalk

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •