Ergebnis 1 bis 5 von 5

Thema: +cme error: 25

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Registriert seit
    17.09.2005
    Beiträge
    1.480

    +cme error: 25

    Servus miteinander!

    Ich versuche derzeit über ein FRT eine SDS an ein HRT zu verschicken, bekomme es aber ums verrecken nicht so wirklich hin.
    Soweit ich mich in die ETSI Dokumente und die ganzen AT Commands eingelesen habe, sollte es doch theoretisch mit folgenden Befehlen klappen:

    at+ctsds=12,0 // setze AI Service Typ 12 => SDS mit TL 4, Zieladressenformat: SSI
    at+cmgs=xxxxxxx,80 // Ziel-SSI + Length von Header und Text
    82000101536572766173 =>

    Protokoll identifier: 130 (Text Messaging)
    Delivery Report: negativ
    Storage/forward control: negativ
    Reference: 1
    Timestamp: not used
    Text coding schema: ISO-8859-1
    Text: Servas

    Als Ergebnis kassiere ich jedesmal einen "+CME ERROR: 25" => "Invalid characters in text string".
    Hat mir zufällig jemand einen Hinweis, wo ich mich noch einlesen sollte oder evtl. sogar eine Aussage, was ich falsch mache?

    Mein Gefühl sagt mir irgendwie, dass ich einen Fehler beim +ctsds mache.
    Schicke ich nämlich nur reinen ASCII-Text, kommt die SDS an der PEI vom HRT an (wird aber nicht in der Message-Liste aufgeführt).

    Ich finde nur ums verrecken keine Liste der möglichen Parameter vom +ctsds.
    Derzeit sind mir nur 12 (TL-4) und 13 (Status) bekannt...

    /edit:
    Liste gefunden - ich hatte in einer andere Version des Dokumentes:
    https://www.etsi.org/deliver/etsi_en...05v020500a.pdf // 6.17.3
    Geändert von Freakmaster (29.03.2021 um 19:24 Uhr) Grund: Korrektur

  2. #2
    Registriert seit
    30.07.2012
    Beiträge
    219
    probier doch mal:
    AT+CTSDS=12,0,,,1

  3. #3
    Registriert seit
    17.09.2005
    Beiträge
    1.480
    Habe ich auch schon getestet => Ergibt leider das gleiche Ergebnis...
    MFG Flo

  4. #4
    Registriert seit
    17.09.2005
    Beiträge
    1.480
    So, endlich ein Stückchen weiter gekommen...
    Es liegt so wie es ausschaut an der Eingabe vom \x1a // ctrl+Z // 026 character.

    Gebe ich ihn im Putty direkt per ALT+026 ein => Fehler
    Kopiere ich das Zeichen z.B. aus Notepad++ heraus (per ALT+026 eingegeben), gehts.
    MFG Flo

  5. #5
    Registriert seit
    17.09.2005
    Beiträge
    1.480
    So, und mittlerweile klappts auch vollständig.
    Es lag effektiv nicht am Trennzeichen, sondern tatsächlich an "fehlerhaften" Userdaten.

    82000101536572766173 <= so hatte ich es ursprünglich getestet.
    82000101202020202020202020202020202020202020202020 202020536572766173 <= so klappts.

    Nach den 4 Byte TL-Header müssen 24 byte angefügt werden.
    Inhalt hab ich jetzt mal Leerzeichen getestet.
    MFG Flo

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •